INTRODUCTION TO GIMP

GIMP provides a comprehensive toolbox in order to quickly perform basic tasks such as
making selections or drawing paths. The many tools contained within GIMP's toolbox are

discussed in detail here.

GIMP has a diverse assortment of tools that let you perform a large variety of tasks. The tools

can be thought of as falling into five categories:

e Selection tools, which specify or modify the portion of the image that will be affected by
subsequent actions;

e Paint tools, which alter the colors in some part of the image;

o Transform tools, which alter the geometry of the image;

e Color tools, which alter the distribution of colors across the entire image;

e Other tools, which don't fall into the other four categories.

e Toolbox - Tool Options sl 2

Kl
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Most tools can be activated by clicking on an icon in the Toolbox. By default, some tools
are accessible only via the menus (namely the Color tools are accessible only either as Colors or
as Tools — Colors). Every tool, in fact, can be activated from the Tools menu; also, every tool can

be activated from the keyboard using an accelerator key.
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In the default setup, created when GIMP is first installed, not all tools show icons in the
Toolbox: the Color tools are omitted. You can customize the set of tools that are shown in the
Toolbox through Edit — Preferences — Toolbox. There are two reasons you might want to do
this: first, if you only rarely use a tool, it might be easier to find the tools you want if the distracting
icon is removed; second, if you use the Color tools a lot, you might find it convenient to have icons
for them easily available. In any case, regardless of the Toolbox, you can always access any tool

at any time using the Tools menu from an image menubar.

The shape of the cursor changes when it is inside an image, to one that indicates which tool
is active (if in Preferences you have set Image Windows — Mouse Pointers — Pointer mode —

Tool icon).
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EX.NO.1 LOGO CREATION

AIM :

To create a logo using Gimp tool.
ALGORITHM / PROCEDURE:
Step 1 : Open GIMP icon.
Step 2 : Select file -> new.
Step 3 : Set height, width and resolution of your logo.

Step 4 : Select Bucket fill tool -> select pattern fill->select any pattern and click on your

workspace to set background of your logo.
Step 5 : Select text tool and type text for your logo.
Step 6 : Select color icon to change color of your text.

Step 7 : To insert an image select file -> open as layers and select your image and use scale tool

to resize image.
Step 8 : If you want to add more effects on your logo select ->filters ->select any options.

Step 9 : After designing your logo select file ->export ->select file format and location and save

your logo.

OUTPUT:

RESULT:

Thus the logo is created successfully using GIMP.
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EX.NO.2 TEXT ANIMATION

AIM:

To create text animation using GIMP.

ALGORITHM / PROCEDURE:

Step 1: Open GIMP icon.
Step 2: Select file -> new.
Step 3: Set height, width and resolution of your workspace.

Step 4: Select Bucket fill tool -> select pattern fill->select any pattern and click on your

workspace to set background.
Step 5: Select text tool and type texts.
Step 6: Select color icon to change color of your text.

Step 7: Select filter ->animation->select any option(blend, spinning globe,waves,rippling,burn-

in) to animate text.
Step 8: Select filter ->play back.

Step 9: To save file->export->select file format->save. Applying spinning globe.
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OUTPUT:

1 Animation Playback: [Untitled] — m] >

1 olea o 21 A &

A ALAX

RESULT:

Thus text animation is created successfully using GIMP.
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INTRODUCTION TO AUDACITY

Control Tool Bar:
= g |
]T‘é—'ﬂ W) ) ®)n !
Hiye. : H| * |
Editing tools:
i Selection tool — For selecting the range of audio you want to edit or listen
- to
e
e Envelope tool — For changing the volume over driver
i Draw tool — For modifying individual samples
_ﬂ Zoom tool- for zooming in and out.
ad

Time shift tool — For sliding tracks left or right

Xk | Multi tool — lets you access all of these tools at once depending on the
location of the mouse and the keys you are holding down.

Audio control button:
*/ SKkip to Start — moves the cursor to time 0. If you press Play at this point, you
project will play from the beginning.
Play — starts playing audio at the cursor position. If some audio is selected,
only the selection is played.

Loop —if you hold down the Shift key, the Play button changes to a Loop
button, which lets you keep playing the selection over

Record — starts recording audio at the project sample rate (the sample rate in
the lower—left corner of the window). The new track begin at the current
cursor position, so click the "Skip to Start" button first if you want the
track to begin at time 0.
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n  Pause — temporarily stops playback or recording until you press pause again.

Stop — stops recording or playing. You must do this before applying effects,
saving or exporting.

» | SKkip to End — moves the cursor to the end of the last track.

Mixer tool bar:

o ..o gh PR . g, Mie |

The Mixer Toolbar has three controls, used to set the vohlme levels of your
audio device and choose the input source. The leftmost slider controls the output
vohlme, the other slider controls the recording voh1me, and the control on the right
lets you choose the input source (such as "Microphone", "Line In", "Audio CD",
etc.). Use the Record Level Meter to set the correct level
Changing these controls has no effect on the audio data in you- project - in other
words it doesn't matter what the output volume level is when you Export or Save a
project - the end result is the same.

Edit toolbar:

All of the buttons on this toolbar perform action - and with couple of
exceptions, they're on just shortcuts of existing menu items to save you
Holding the mouse over a tool will show a “tooltip” in case you forgot which one is
which.
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Cut.

Copy.

Paste.

Trim away the audio outside the selection.

Silence the selected audio.

Undo.

Redo.

Zoom In.

Zoom out.

Fit selection in window - zooms until the selection just fits inside the window.

Fit project in window - zooms until all of the audio just fits inside the window.
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EX.NO.1 SILENCING TRIMMING AND DUPLICATING AUDIO

SIGNAL

AIM:

To apply silence, trim and duplicate effects for a selected audio signal.
ALGORITHM / PROCEDURE:
A. Silencing:

1. Open Audacity and open a new audio file.

2. Select a particular region to be silence and go to Edit -» Silence or Ctrl + L.

3. To duplicate a particular part, select the part and go to Edit -»Copy and paste it in
any place of the audio track.

4. Play the track using the play button in the toolbar.

5. Save the audio file.

B. Trimming :

1. Open Audacity and open a new audio file.

2. To zoom in to get a closer look at the waveform, first choose the Selection

Tool I , then click near the point you're interested in, then click the Zoom
In button to see the detail you need.

3. Select a particular region to be trimmed using I button.

'd
4. Select g\ cut icon from the toolbar.

5. Play the track using the play button in the toolbar.
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6. Save the audio signal.
C. Duplicating :

1. Open Audacity and open a new audio file.

2.To zoom in to get a closer look at the waveform, first choose the Selection

Tool I , then click near the point you're interested in, then click the Zoom In button

to see the detail you need.

3. Select a particular region to be duplicated using I button.
4. Play the track using the play button in the toolbar.

5. Save the audio signal.

OUTPUT:

i) Original audio signal:
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ii) After Silencing
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iii) After Trimming:
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C) Duplicating

= mm WH“F'“T""" "'N
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g
RESULT :

Thus an audio source has been duplicated and silenced at a particular part using Audacity.
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EX.NO.2 ADVANCED EFFECTS TO AUDIO SIGNAL

AIM :

To apply various audio transitions to an audio signal.

ALGORITHM / PROCEDURE:

1. Open Audacity and open a new audio track.

2. Select a part of it and go to Effect->Reverse. Play to hear the effect.

3. Select another part of the track and go to Effect -» WahWah and set the value as
required. Play to hear the effect.

4. Apply various effects of user defined.

5. Audio effects have now been created.

OUTPUT :
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RESULT:

Thus various effects have been applied to an audio signal.
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WINDOWS MOVIE MAKER

EX.NO.1 APPLICATION OF SOME EFFECTS TO VIDEO

AIM:

To apply some effects to video using windows movie maker.
ALGORITHM / PROCEDURE:

Step 1: Open movie maker
Step 2: To add video and images select add videos and photos icon.
Step 3: To add music select add music icon.

Step 4: Your selected images/videos and music displayed on bottom of your window. here you

can manage your movie.
Step 5: To apply effects click animation and visual effects icon.

Step 6: After applying all effects select export to save.

OUTPUT:
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Original video

After applying grayscale effect

RESULT:

Thus the effect to video is implemented successfully using windows movie maker.
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EX.NO.2

CREATING TITLES IN VIDEO

AIM:

To create titles in videos using windows movie maker.

ALGORITHM / PROCEDURE:

Step 1: Open movie maker

Step 2: To add video and images select add videos and photos icon.

Step 3: To add effects on your video refer the procedure of previous exercise.

Step 4: Select text/credit icon->select title->add title for your movie

Step 5: To save click export from file and name your movie and then save.

OUTPUT:

RESULT:

Thus titles in videos is created successfully using windows movie maker.
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INTRODUCTION TO SWISH MAX 2

Swish Max 2 is easy to use and produces complex animations with text,
images, graphics, video and sound. Swish Max has tools for creating lines,
rectangles, ellipses, vector and freehand curves, motion paths, movie clips, rollover
buttons, and input forms all in an intuitive easy-to-use interface. Swish Max also

includes a large range of preset multimedia effects, components and vector art.
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Selection Tool k ﬁ —» SubSelection Tool

Transform Tool 1—~:': ::]—b Perspective Tool

?ﬂms"m‘ «— 1@ 24—» MotionPath Tool

Line Tool —/ /—P Pencil Tool

Ellipse Tool A’O D—b Rectangle Tool

Autoshape D ’_
Tool
Qf? q_p Zoom Tool

Hand Tool 4

by moving or reshaping the object.

B

Subselection Tool

(A)

Tools:

Tools are modal commands that
determine what Swish Max does when you
click and drag the mouse on the workspace.
You can select a tool by clicking one of the
options in the Tool box, which is located in the
top-left of the Layout panel. You can only
select one tool at a time.

Selection Tool (V)

The selection tool is used for selecting

entire Objects and transforming graphic objects

It reshapes graphic Objects by clicking and dragging the vertices the object

outline path.

(228
(.11

Transform Tool **% (Q)

It transforms graphic Objects by clicking and dragging.

Perspective Tool (I) 3:]

Dragging the handles provided modifies the Perspective of the Object.

Fill Transform (F) =

It transforms an Object's gradient or image fill without transforming the

Object.

o
0

Motion Path (M)

It plots a Motion Path for the selected Object by clicking and dragging.

Line Tool (L) rd
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It draws a line.

Pencil Tool (N) ﬁ

It draws a freehand line object.

Pen Tool (P) ﬂ
The Pen tool draws a set of connected curves or line segments.

Text Tool (T) gt
The Text tool draws a Text Object.

Ellipse Tool (E) D
It draws an ellipse or circle.

Rectangle Tool (R) C
It draws a rectangle or square.

AutoShapes -

AutoShapes allows you to draw a number of predetermined shapes.

Hand Tool (H) S 4
Pans around the workspace in the Layout pannel by clicking and dragging.

Zoom Tool (Z) q
It Zooms in/out of the workspace in the Layout pannel using the mouse.

Timeline:

The 'Timeline' Panel contains time-based properties for the current Scene. The
Scene is made up of a series of Frames, in the same way that a motion picture is
W% Add Script
X Delete

1€¢ Shiink.
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made up of Frames. The Timeline is a visual representation of the Frames with the
first Frame af the left and last Frame at the right

Scene: A Scene is a collection of Objects that are animated over a number of Frames.

Scripting: o ';E._
Scripting can be used to

define Actions that will occur N —

at a specific Frame, when two ‘f“_’_,,_,_

Objects collide, or when some
other external input is applied
to the Movie.

Script Panel

Effects:

Effects are animations that change the appearance of an Object over time. You
can add, modify and coordinate Effects using the Timeline panel.
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Events:

All Actions are triggered in response to an Event. Any Scripting object can have

Events associated with it. When an

the
Break. with: EF!andom Folygons i
Mumnber: Reqular Grid
Tri lar Mesh
Random seed: e : =
Random Triangles
@) Allow non-tia @ Random Polygons
() Triangulate all pieces
Inflate all pieces by: 025 | pixels
— are

that Event.
There are three types of events:
Frame

e Button
e Self

Input Text Objects also have the
additional Events on(changed)

]
.
]
¥
¥
"
"
[
Condtinal ¥
Legpang L3
E
Exveptiore (SWFF+) »
Dbz L4

Break. with:

MHumber: 100 .
Ranhdom seed: 520

Break into Pieces e

Fandam Polpgons =

@ Allow non-tiangular pieces

() Tnangulate all pieces

Inflate all pieces by:

Cazcade order
S HE W &% %88
E WM 2 W e %S

onSelfEventChanged available.

Frame Event is selected

(025 | pixels

Event occurs,
Event
handling
routine
executes any
Actions that
defined for
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EX.NO.1

TEXT EFFECTS

AIM :

To apply various text effects to the predefined formats.

ALGORITHM \ PROCEDURE :

1.

Create a Static text object and place it on the Stage.

In the Outline Panel, right-click on the text object and select Copy Object.
Then, use the Edit menu and select Paste in Place. Y ou should now have
two text objects at the exact same location on the stage.

Select the bottom text object and use Modify -» Break -» Break into
pieces.

In the Break into Pieces settings window, use the drop-down menu next to
Break With: " and select Random Polygons.

Allow  non-triangular pieces or Triangulate all pieces... again, this
is up to you as it is difficult to tell any difference at such small sizes.
Inflate all pieces by 0.25 pixels. This helps seal the scenes in between in
each piece.

When SWiSHmax has finished breaking the object into pieces, you should

end up with a Group.
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8. In the Timeline Panel, right-click at Frame 1 on the row for the top text
object and select the Place effect.
9. Next, right-click at Frame 1 on the row for the Group object and select the
Remove effect.
10.Next, right-click at Frame 20 on the row for the top text object and select the
Remove effect.
11. Next, right-click at Frame 20 on the row for the Group object and select

Disappear from Position | Wild — Splatter.

OUTPUT:

ANNAMALAI

qN‘.*J/M - u ’x |

RESULT :

Thus the dust effect has been applied to the custom text using Swish.
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EX.NO.2 PRELOADER

AIM:
To create a pre-loader effect manually using Swish.

ALGORITHM \ PROCEDURE :

1. Create a Dynamic TextBox name it as myMsgObj and name its variable
myMsg.
2. Create a rectangle for 20x20 pixels.

3. Then convert it into movie clip .

i }Illllﬁlllllll[illllllf:lIII2|:I|IIIIEEIIIII:}[IIIIIISEIIIIEIIII45II
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T Ten Vel

g Splae 2]

4. Name the movie clip as © progBar ’.

5. Then type the following coding on Script -> Scene 1:

onFrame(1)

stop();
}

onSelfEvent(enterFrame)

{
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pLoaded=this.percentLoaded();
tBytes=this.getBytesTotal();
myMsg=pLoaded+"%Loaded of "+tBytes+" bytes";
progBar width=pLoaded;

if(pLoaded==100)

play();

}
6. The preloader is added.

OUTPUT :

100% Loaded of 19861 bytes

RESULT :

Thus the pre-loader effect has been created using Swish.
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FLASH

EX.NO.1 CHANGING THE SHAPE OF THE OBJECT

AIM:

To create Shape Tweening using Flash.

ALGORITHM \ PROCEDURE:

1.

. A = 9

Create a New Flash Document.

Click the Oval Tool g on the Tools.

Using the Fill Color Option @& WA select the attractive color to the Shape.
Create a Circle Object on Frame 1.

Click the 40" Frame and press F6.

Now Delete the Circle Object then Create a new Rectangle Object by using
Rectangle  Tool.  Then change the color of the Rectangle Object
using Fill Color. E

Select the 20" Frame on Timeline, then Change the Tween option to the Shape

on the Properties window.

| ¥ Properties

ll Frame Tween: |None p4
Fran be hone
ndbimons Motion

Label type:

Now Shape Tweening is completed. Press Ctrl + Enter.

Shape tweening:
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RESULT:

Thus the shape tweening has been created using Flash.
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EX.NO. 2 IMAGE VIEWING USING MASK

AIM:
To create Masking using Flash.
ALGORITHM \ PROCEDURE:

1. Create a New Flash Document.

2. Import any Image on Frame 1.

3. Create Motion Tweening for that Image. So that the Image can move from
left to right side of the screen.

4. Insert keyFrame.

5. Now Lock the Layer [ using @ Lock.

6. Insert another Layer 2, 4 and create any Objects (Ovel/ Rectangle/Any
Shapes) for Object Masking , Or Type any Text with different Font & size
for Text Masking.

7. Right click on Layer 2 then select Mask.

8. Now the Masking is created. Run the animation using Ctrl + Enter.
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OUTPUT:

Object Masking...

Text Masking...

RESULT:

Thus the Masking effecting has been created using Flash.
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PHOTO IMPACT

EX.NO.1 TEXT EFFECTS

AIM:

To create custom effects to the pre defined font styles.

ALGORITHM \ PROCEDURE:

1. Open a new image file.

2. Create any text with user defined font style and size.

3. Select the text and Select Object -> convert Object Type ->From

Text/Image to Path.

4. Switch to the Path Edit Tool |™. | on the Tool Panel, you will then see

from the wireframe structure that the text has become a path and can be

edited as such.

5. Use the dots to create custom design.
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Output:

Before:

DEPARTMENT OF COMPUTERSCIENCE

After:

DEPARTMENT OF OMPLITER SclerrcE

RESULT:

Thus custom effect has been applied to the pre defined font using Ulead Photo

Impact.
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EX.NO.2

IMAGE SLICING

AIM :

To slice a portion from a picture and merge it into another using Ulead

Photo Impact.

ALGORITHM \ PROCEDURE :

1.
2.
3.

Open an image from which a specific portion has to be sliced.
Select the image and go to Object -> Extract Object.

By custom brush size and color, sketch out the portion to be parted and
click next.

Click extract and select the portion which should not to be sliced and
click next.

Adjust transparency and other details and click next.
Now the portion to be sliced alone is selected.

Import and background image and drag the selected image to the
background image.

Now the user defined image is ready.
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OUTPUT :

BEFORE

AFTER

RESULT:

Thus photo slicing and merging has been done using Ulead PhotoImpact.
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